#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{2}(0[1-9]|1[012])(0[1-9]|[12][0-9]|3[01])\d{6}$"
Local $sString = "190131958103" & @CRLF & _
"201331958103" & @CRLF & _
"190100958103" & @CRLF & _
"190132958103" & @CRLF & _
"190031958103" & @CRLF & _
"441201485383" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")