package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{2}(0[1-9]|1[012])(0[1-9]|[12][0-9]|3[01])\d{6}$`)
var str = `190131958103
201331958103
190100958103
190132958103
190031958103
441201485383
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}