import re
regex = re.compile(r"^\d{2}(0[1-9]|1[012])(0[1-9]|[12][0-9]|3[01])\d{6}$", flags=re.MULTILINE)
test_str = ("190131958103\n"
"201331958103\n"
"190100958103\n"
"190132958103\n"
"190031958103\n"
"441201485383\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")