re = /^\d{2}(0[1-9]|1[012])(0[1-9]|[12][0-9]|3[01])\d{6}$/m
str = '190131958103
201331958103
190100958103
190132958103
190031958103
441201485383
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end