$re = '/^((([1-9][0-9]{0,2})(,\d{3})*(\.\d+)?)|(([1-9][0-9]*)(\.\d+)?))$/m';
$str = '0,999,999,999,999,999.0
10,999,999,999,999,9899.9
99,999
9.99
09,999
0999998
09999
9.9
999,99
9,999
999.0
abc123
66666666666666666666.098
888888888
0.999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);