import Foundation
let pattern = #"^((([1-9][0-9]{0,2})(,\d{3})*(\.\d+)?)|(([1-9][0-9]*)(\.\d+)?))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0,999,999,999,999,999.0
10,999,999,999,999,9899.9
99,999
9.99
09,999
0999998
09999
9.9
999,99
9,999
999.0
abc123
66666666666666666666.098
888888888
0.999
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)