// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((([1-9][0-9]{0,2})(,\d{3})*(\.\d+)?)|(([1-9][0-9]*)(\.\d+)?))$").unwrap();
let string = "0,999,999,999,999,999.0
10,999,999,999,999,9899.9
99,999
9.99
09,999
0999998
09999
9.9
999,99
9,999
999.0
abc123
66666666666666666666.098
888888888
0.999";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}