import re
regex = re.compile(r"^((([1-9][0-9]{0,2})(,\d{3})*(\.\d+)?)|(([1-9][0-9]*)(\.\d+)?))$", flags=re.MULTILINE)
test_str = ("0,999,999,999,999,999.0\n"
"10,999,999,999,999,9899.9\n"
"99,999\n"
"9.99\n"
"09,999\n"
"0999998\n"
"09999\n"
"9.9\n"
"999,99\n"
"9,999\n"
"999.0\n"
"abc123\n"
"66666666666666666666.098\n"
"888888888\n"
"0.999")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")