package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\w*|\(.*\))(\(class=(\".*\")\))`)
var str = `+image(class="sumup-illustration, vector" src="/sumup-x-debitoor-guide/final_illustration_sumup_en.svg" alt="Meet a better way to stay on top of your SumUp payments")
+image(class="classTest1, classTest2, classTest3, classTest4")
+grid__item("md-4", "md-vertical-4x-gutter", "xs-first", "md-last")(class="accent, button, link")
+button(class="red")`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}