const regex = /(?:\w*|\(.*\))(\(class=(\".*\")\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\w*|\\(.*\\))(\\(class=(\\".*\\")\\))', 'gm')
const str = `+image(class="sumup-illustration, vector" src="/sumup-x-debitoor-guide/final_illustration_sumup_en.svg" alt="Meet a better way to stay on top of your SumUp payments")
+image(class="classTest1, classTest2, classTest3, classTest4")
+grid__item("md-4", "md-vertical-4x-gutter", "xs-first", "md-last")(class="accent, button, link")
+button(class="red")`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}