// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?:\w*|\(.*\))(\(class=(\".*\")\))"#).unwrap();
let string = "+image(class=\"sumup-illustration, vector\" src=\"/sumup-x-debitoor-guide/final_illustration_sumup_en.svg\" alt=\"Meet a better way to stay on top of your SumUp payments\")
+image(class=\"classTest1, classTest2, classTest3, classTest4\")
+grid__item(\"md-4\", \"md-vertical-4x-gutter\", \"xs-first\", \"md-last\")(class=\"accent, button, link\")
+button(class=\"red\")";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}