#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bhttp:\/\/[a-zA-Z0-9]{1,}\.com\/(([a-zA-Z0-9]{1,}\/){1,})?(([a-zA-Z0-9]{1,}\.png)|([a-zA-Z0-9]{1,}\.jpg)|([a-zA-Z0-9]{1,}\.gif))\b$"
Local $sString = "http://site.com/folder/1/2/asd/sdasd/1.png" & @CRLF & _
"file.png" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")