re = /\bhttp:\/\/[a-zA-Z0-9]{1,}\.com\/(([a-zA-Z0-9]{1,}\/){1,})?(([a-zA-Z0-9]{1,}\.png)|([a-zA-Z0-9]{1,}\.jpg)|([a-zA-Z0-9]{1,}\.gif))\b$/m
str = 'http://site.com/folder/1/2/asd/sdasd/1.png
file.png
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end