const regex = /\bhttp:\/\/[a-zA-Z0-9]{1,}\.com\/(([a-zA-Z0-9]{1,}\/){1,})?(([a-zA-Z0-9]{1,}\.png)|([a-zA-Z0-9]{1,}\.jpg)|([a-zA-Z0-9]{1,}\.gif))\b$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bhttp:\\\/\\\/[a-zA-Z0-9]{1,}\\.com\\\/(([a-zA-Z0-9]{1,}\\\/){1,})?(([a-zA-Z0-9]{1,}\\.png)|([a-zA-Z0-9]{1,}\\.jpg)|([a-zA-Z0-9]{1,}\\.gif))\\b$', 'gm')
const str = `http://site.com/folder/1/2/asd/sdasd/1.png
file.png
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}