// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bhttp:\/\/[a-zA-Z0-9]{1,}\.com\/(([a-zA-Z0-9]{1,}\/){1,})?(([a-zA-Z0-9]{1,}\.png)|([a-zA-Z0-9]{1,}\.jpg)|([a-zA-Z0-9]{1,}\.gif))\b$").unwrap();
let string = "http://site.com/folder/1/2/asd/sdasd/1.png
file.png
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}