#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[httpsHTTPS]+\:\/\/domen\.(com|ru)\/\d\/audio\/\d{5,7}\/[a-zA-Z0-9_.-]+\.mp3"
Local $sString = "https://domen.com/2/audio/39761/mobile/otnimajj-ili-otnimut-u-tebja-tom-1-chast-1-1.mp3" & @CRLF & _
"https://domen.com/2/audio/39761/008-otnimajj-ili-otnimut-u-tebja-glava-8.mp3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")