use strict;
my $str = 'https://domen.com/2/audio/39761/mobile/otnimajj-ili-otnimut-u-tebja-tom-1-chast-1-1.mp3
https://domen.com/2/audio/39761/008-otnimajj-ili-otnimut-u-tebja-glava-8.mp3';
my $regex = qr/[httpsHTTPS]+\:\/\/domen\.(com|ru)\/\d\/audio\/\d{5,7}\/[a-zA-Z0-9_.-]+\.mp3/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}