re = /[httpsHTTPS]+\:\/\/domen\.(com|ru)\/\d\/audio\/\d{5,7}\/[a-zA-Z0-9_.-]+\.mp3/m
str = 'https://domen.com/2/audio/39761/mobile/otnimajj-ili-otnimut-u-tebja-tom-1-chast-1-1.mp3
https://domen.com/2/audio/39761/008-otnimajj-ili-otnimut-u-tebja-glava-8.mp3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end