# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[httpsHTTPS]+\:\/\/domen\.(com|ru)\/\d\/audio\/\d{5,7}\/[a-zA-Z0-9_.-]+\.mp3"
test_str = ("https://domen.com/2/audio/39761/mobile/otnimajj-ili-otnimut-u-tebja-tom-1-chast-1-1.mp3\n"
"https://domen.com/2/audio/39761/008-otnimajj-ili-otnimut-u-tebja-glava-8.mp3")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.