#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/abc_d\/efg_h\/(?P<unitpath_1>\w[a-zA-Z_].*)\/(?P<unitpath_2>\d.*)\/(?P<unitpath_3>\w[a-zA-Z_]*)"
Local $sString = "/abc_d/efg_h/abcd_ef/1234/ghi_jk/" & @CRLF & _
"/abc_d/efg_h/zxcv_vf/56789/sdfg_h/" & @CRLF & _
"/abc_d/efg_h/dfghh_h/5y865/ghjk_r/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")