// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\/abc_d\/efg_h\/(?P<unitpath_1>\w[a-zA-Z_].*)\/(?P<unitpath_2>\d.*)\/(?P<unitpath_3>\w[a-zA-Z_]*)").unwrap();
let string = "/abc_d/efg_h/abcd_ef/1234/ghi_jk/
/abc_d/efg_h/zxcv_vf/56789/sdfg_h/
/abc_d/efg_h/dfghh_h/5y865/ghjk_r/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}