re = /\/abc_d\/efg_h\/(?P<unitpath_1>\w[a-zA-Z_].*)\/(?P<unitpath_2>\d.*)\/(?P<unitpath_3>\w[a-zA-Z_]*)/m
str = '/abc_d/efg_h/abcd_ef/1234/ghi_jk/
/abc_d/efg_h/zxcv_vf/56789/sdfg_h/
/abc_d/efg_h/dfghh_h/5y865/ghjk_r/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end