const regex = /\/abc_d\/efg_h\/(?P<unitpath_1>\w[a-zA-Z_].*)\/(?P<unitpath_2>\d.*)\/(?P<unitpath_3>\w[a-zA-Z_]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/abc_d\\\/efg_h\\\/(?P<unitpath_1>\\w[a-zA-Z_].*)\\\/(?P<unitpath_2>\\d.*)\\\/(?P<unitpath_3>\\w[a-zA-Z_]*)', 'gm')
const str = `/abc_d/efg_h/abcd_ef/1234/ghi_jk/
/abc_d/efg_h/zxcv_vf/56789/sdfg_h/
/abc_d/efg_h/dfghh_h/5y865/ghjk_r/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}