use strict;
my $str = '/abc_d/efg_h/abcd_ef/1234/ghi_jk/
/abc_d/efg_h/zxcv_vf/56789/sdfg_h/
/abc_d/efg_h/dfghh_h/5y865/ghjk_r/';
my $regex = qr/\/abc_d\/efg_h\/(?P<unitpath_1>\w[a-zA-Z_].*)\/(?P<unitpath_2>\d.*)\/(?P<unitpath_3>\w[a-zA-Z_]*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}