using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:<#.*?#>|[^#])*(#.*)?";
string input = @"-----------------
---MATCH CASES---
------------------------------------------------
$text = ""Hello""\t# Comment after tab
$text+= #Comment without space after hash
Write-Host $text# Comment without space before hash
#Comment line with no whitespaces around'
Write-Host ""Hello""#Comment in the end with no whitespaces around'
# Comment with whitespaces around '
# Consecutive comments
# Last line comment without line ending in the end
$text+= #Comment with < inside
$text+= #Comment ending with >
$text+= #Comment with <# inline comment #>
# Normal comment
Write-Host ""Comment without text"" #
An <# inline comment #> preceding a #comment
An <# inline # comment containing a # #> preceding a #comment
Two <# inline #> comments <# to be #> skipped # comment
--------------------
---NO MATCH CASES---
------------------------------------------------
Write-Host ""Hello""
Write-Host ""World""
Write-Host ""Non-empty line""
$text = ""Hello"" <# block comment #> + ""World""
$text = ""Hello"" +<#comment#>""World""
<# Block comment in a line #>
Write-Host ""Hello world <# Block comment in the end of line #>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}