use strict;
my $str = '-----------------
---MATCH CASES---
------------------------------------------------
$text = "Hello"\\t# Comment after tab
$text+= #Comment without space after hash
Write-Host $text# Comment without space before hash
#Comment line with no whitespaces around\'
Write-Host "Hello"#Comment in the end with no whitespaces around\'
# Comment with whitespaces around \'
# Consecutive comments
# Last line comment without line ending in the end
$text+= #Comment with < inside
$text+= #Comment ending with >
$text+= #Comment with <# inline comment #>
# Normal comment
Write-Host "Comment without text" #
An <# inline comment #> preceding a #comment
An <# inline # comment containing a # #> preceding a #comment
Two <# inline #> comments <# to be #> skipped # comment
--------------------
---NO MATCH CASES---
------------------------------------------------
Write-Host "Hello"
Write-Host "World"
Write-Host "Non-empty line"
$text = "Hello" <# block comment #> + "World"
$text = "Hello" +<#comment#>"World"
<# Block comment in a line #>
Write-Host "Hello world <# Block comment in the end of line #>';
my $regex = qr/^(?:<#.*?#>|[^#])*(#.*)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}