const regex = /^(?:<#.*?#>|[^#])*(#.*)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:<#.*?#>|[^#])*(#.*)?', 'gm')
const str = `-----------------
---MATCH CASES---
------------------------------------------------
\$text = "Hello"\\t# Comment after tab
\$text+= #Comment without space after hash
Write-Host \$text# Comment without space before hash
#Comment line with no whitespaces around'
Write-Host "Hello"#Comment in the end with no whitespaces around'
# Comment with whitespaces around '
# Consecutive comments
# Last line comment without line ending in the end
\$text+= #Comment with < inside
\$text+= #Comment ending with >
\$text+= #Comment with <# inline comment #>
# Normal comment
Write-Host "Comment without text" #
An <# inline comment #> preceding a #comment
An <# inline # comment containing a # #> preceding a #comment
Two <# inline #> comments <# to be #> skipped # comment
--------------------
---NO MATCH CASES---
------------------------------------------------
Write-Host "Hello"
Write-Host "World"
Write-Host "Non-empty line"
\$text = "Hello" <# block comment #> + "World"
\$text = "Hello" +<#comment#>"World"
<# Block comment in a line #>
Write-Host "Hello world <# Block comment in the end of line #>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}