import re
regex = re.compile(r"^(?:<#.*?#>|[^#])*(#.*)?", flags=re.MULTILINE)
test_str = ("-----------------\n"
"---MATCH CASES---\n"
"------------------------------------------------\n"
"$text = \"Hello\"\\t# Comment after tab\n"
"$text+= #Comment without space after hash\n"
"Write-Host $text# Comment without space before hash\n"
"#Comment line with no whitespaces around'\n"
"Write-Host \"Hello\"#Comment in the end with no whitespaces around'\n"
"# Comment with whitespaces around '\n"
"# Consecutive comments\n"
"# Last line comment without line ending in the end\n"
"$text+= #Comment with < inside\n"
"$text+= #Comment ending with >\n"
"$text+= #Comment with <# inline comment #>\n"
"# Normal comment\n"
"Write-Host \"Comment without text\" #\n"
"An <# inline comment #> preceding a #comment\n"
"An <# inline # comment containing a # #> preceding a #comment\n"
"Two <# inline #> comments <# to be #> skipped # comment\n\n\n\n\n\n"
"--------------------\n"
"---NO MATCH CASES---\n"
"------------------------------------------------\n"
"Write-Host \"Hello\"\n"
"Write-Host \"World\"\n"
"Write-Host \"Non-empty line\"\n"
"$text = \"Hello\" <# block comment #> + \"World\"\n"
"$text = \"Hello\" +<#comment#>\"World\"\n"
"<# Block comment in a line #>\n"
"Write-Host \"Hello world <# Block comment in the end of line #>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")