import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:<#.*?#>|[^#])*(#.*)?";
final String string = "-----------------\n"
+ "---MATCH CASES---\n"
+ "------------------------------------------------\n"
+ "$text = \"Hello\"\\t# Comment after tab\n"
+ "$text+= #Comment without space after hash\n"
+ "Write-Host $text# Comment without space before hash\n"
+ "#Comment line with no whitespaces around'\n"
+ "Write-Host \"Hello\"#Comment in the end with no whitespaces around'\n"
+ "# Comment with whitespaces around '\n"
+ "# Consecutive comments\n"
+ "# Last line comment without line ending in the end\n"
+ "$text+= #Comment with < inside\n"
+ "$text+= #Comment ending with >\n"
+ "$text+= #Comment with <# inline comment #>\n"
+ "# Normal comment\n"
+ "Write-Host \"Comment without text\" #\n"
+ "An <# inline comment #> preceding a #comment\n"
+ "An <# inline # comment containing a # #> preceding a #comment\n"
+ "Two <# inline #> comments <# to be #> skipped # comment\n\n\n\n\n\n"
+ "--------------------\n"
+ "---NO MATCH CASES---\n"
+ "------------------------------------------------\n"
+ "Write-Host \"Hello\"\n"
+ "Write-Host \"World\"\n"
+ "Write-Host \"Non-empty line\"\n"
+ "$text = \"Hello\" <# block comment #> + \"World\"\n"
+ "$text = \"Hello\" +<#comment#>\"World\"\n"
+ "<# Block comment in a line #>\n"
+ "Write-Host \"Hello world <# Block comment in the end of line #>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}