using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"name:\s+['""]?AVP_VERSION['""]?[\s,]+value:\s+['""]?(?<currentValue>[_\-\.\w]+)['""]?";
string input = @"env: [ name: AVP_VERSION, value: 1.18.1 ]
image: registry.access.redhat.com/ubi8
env:
- name: AVP_VERSION
value: ""1.18.0""
command: [ sh, -c ]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}