package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)name:\s+['"]?AVP_VERSION['"]?[\s,]+value:\s+['"]?(?<currentValue>[_\-\.\w]+)['"]?`)
var str = `env: [ name: AVP_VERSION, value: 1.18.1 ]
image: registry.access.redhat.com/ubi8
env:
- name: AVP_VERSION
value: "1.18.0"
command: [ sh, -c ]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}