#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)rr\d---sn-\w{8}.googlevideo.com"
Local $sString = "||rr3---sn-hp57yne7.googlevideo.com^$important" & @CRLF & _
"||rr3---sn-oguelnlz.googlevideo.com^$important" & @CRLF & _
"||rr5---sn-hp57knd6.googlevideo.com^$important"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")