import re
regex = re.compile(r"rr\d---sn-\w{8}.googlevideo.com", flags=re.MULTILINE)
test_str = ("||rr3---sn-hp57yne7.googlevideo.com^$important\n"
"||rr3---sn-oguelnlz.googlevideo.com^$important\n"
"||rr5---sn-hp57knd6.googlevideo.com^$important")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")