using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"_([^_\s]+_[^_\s]+)$";
string input = @"test1_test2_test3_test4_test5
test1_test2_test3_test4 test5
test1_test2_test3___test5";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}