const regex = /_([^_\s]+_[^_\s]+)$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('_([^_\\s]+_[^_\\s]+)$', 'mg')
const str = `test1_test2_test3_test4_test5
test1_test2_test3_test4 test5
test1_test2_test3___test5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}