// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)_([^_\s]+_[^_\s]+)$").unwrap();
let string = "test1_test2_test3_test4_test5
test1_test2_test3_test4 test5
test1_test2_test3___test5";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}