package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)_([^_\s]+_[^_\s]+)$`)
var str = `test1_test2_test3_test4_test5
test1_test2_test3_test4 test5
test1_test2_test3___test5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}