$re = '/_([^_\s]+_[^_\s]+)$/m';
$str = 'test1_test2_test3_test4_test5
test1_test2_test3_test4 test5
test1_test2_test3___test5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);