#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?xs)" & @CRLF & _
"(?<!')(?:'{2})*\B('\b[^'\\]*(?:(?:\\.|\b'\b)[^'\\]*)*') # Single quoted string literal" & @CRLF & _
"| # or" & @CRLF & _
"(?<!")(?:"{2})*\B("\b[^"\\]*(?:(?:\\.|\b"\b)[^"\\]*)*") # Double quoted string literal"
Local $sString = "I am "looking for" a way that doesn't break: "Lorem" & @CRLF & _
"ipsum\" AAAAA" in this case. Or this AAAAA case. Or this 'AAAAA' case." & @CRLF & _
"Isn't this annoying?" & @CRLF & _
"I used to love the song Space Truckin'. It is 'AAAAA'."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")