using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?xs)
(?<!')(?:'{2})*\B('\b[^'\\]*(?:(?:\\.|\b'\b)[^'\\]*)*') # Single quoted string literal
| # or
(?<!"")(?:""{2})*\B(""\b[^""\\]*(?:(?:\\.|\b""\b)[^""\\]*)*"") # Double quoted string literal";
string input = @"I am ""looking for"" a way that doesn't break: ""Lorem
ipsum\"" AAAAA"" in this case. Or this AAAAA case. Or this 'AAAAA' case.
Isn't this annoying?
I used to love the song Space Truckin'. It is 'AAAAA'.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}