import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?xs)\n"
+ "(?<!')(?:'{2})*\\B('\\b[^'\\\\]*(?:(?:\\\\.|\\b'\\b)[^'\\\\]*)*') # Single quoted string literal\n"
+ "| # or\n"
+ "(?<!\")(?:\"{2})*\\B(\"\\b[^\"\\\\]*(?:(?:\\\\.|\\b\"\\b)[^\"\\\\]*)*\") # Double quoted string literal";
final String string = "I am \"looking for\" a way that doesn't break: \"Lorem\n"
+ "ipsum\\\" AAAAA\" in this case. Or this AAAAA case. Or this 'AAAAA' case.\n"
+ "Isn't this annoying?\n"
+ "I used to love the song Space Truckin'. It is 'AAAAA'.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}