const regex = new RegExp('(?xs)
(?<!\\')(?:\\'{2})*\\B(\\'\\b[^\\'\\\\]*(?:(?:\\\\.|\\b\\'\\b)[^\\'\\\\]*)*\\') # Single quoted string literal
| # or
(?<!")(?:"{2})*\\B("\\b[^"\\\\]*(?:(?:\\\\.|\\b"\\b)[^"\\\\]*)*") # Double quoted string literal', 'gm')
const str = `I am "looking for" a way that doesn't break: "Lorem
ipsum\\" AAAAA" in this case. Or this AAAAA case. Or this 'AAAAA' case.
Isn't this annoying?
I used to love the song Space Truckin'. It is 'AAAAA'.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}