# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^'\s*(SELECT)[^']*(FROM)[^']*'|^"\s*(SELECT)[^"]*(FROM)[^"]*"//gm;t' <<< "\"SELECT * FROM table\"
\"
SELECT * FROM table\"
\"\"\"
Use this query here: \"SELECT * FROM table\"
\"\"\"
SELECT * FROM table"