const regex = /^'\s*(SELECT)[^']*(FROM)[^']*'|^"\s*(SELECT)[^"]*(FROM)[^"]*"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\'\\s*(SELECT)[^\']*(FROM)[^\']*\'|^"\\s*(SELECT)[^"]*(FROM)[^"]*"', 'gm')
const str = `"SELECT * FROM table"
"
SELECT * FROM table"
"""
Use this query here: "SELECT * FROM table"
"""
SELECT * FROM table`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);