// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^'\s*(SELECT)[^']*(FROM)[^']*'|^"\s*(SELECT)[^"]*(FROM)[^"]*""#).unwrap();
let string = "\"SELECT * FROM table\"
\"
SELECT * FROM table\"
\"\"\"
Use this query here: \"SELECT * FROM table\"
\"\"\"
SELECT * FROM table";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}