package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m):(ref|doc|term):`([^`]+)\s?<([^:`]+):([^:`]+)>``)
var str = `This are :ref:\`external references<python:reference>\` with a :doc:\`custom title <python:index>\`.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}