$re = '/:(ref|doc|term):`([^`]+)\s?<([^:`]+):([^:`]+)>`/m';
$str = 'This are :ref:`external references<python:reference>` with a :doc:`custom title <python:index>`.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);