// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m):(ref|doc|term):`([^`]+)\s?<([^:`]+):([^:`]+)>`").unwrap();
let string = "This are :ref:`external references<python:reference>` with a :doc:`custom title <python:index>`.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}