package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]+(?:[.,][0-9]+)*$`)
var str = `123
1
12
123.0
123.456
1,23,456
1,23,456.56
12,300.56
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}