$re = '/^[0-9]+(?:[.,][0-9]+)*$/m';
$str = '123
1
12
123.0
123.456
1,23,456
1,23,456.56
12,300.56
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);